WordPress 2017年11月_脆弱性レポート  2017/12/01
2017年11月度のWordPressに関する脆弱性レポートをお知らせします。

11月度全体の脆弱性報告件数としては25件でした。10月度から5件増加しております。
個所別レポート
個所別の発生件数は、それぞれ本体で4件、テーマは0件、プラグインが21件でした。

内容ですが、9月、10月に引き続いて11月も本体に関しての脆弱性が発生しました。
全部で4件発生しており、脆弱性に気を配る必要があることがわかります。

テーマに関しましては今月も脆弱性が発生しませんでした。

また先月に引き続き最多発生はプラグインとなり、脆弱性に気を配る必要があることがわかります。

トピックス
前述のとおり本体に関しましては、脆弱性が4件発生しております。

ブログにて速報しております通り、バージョン4.9以下にクロスサイトスクリプティング(XSS)などの脆弱性が含まれています。

すでに対策バージョン4.9.1がリリースされており、WordPress 3.7以降のすべてのバージョンのセキュリティおよびバグを修正しました。

セキュリティに関しましては、従来で行えたDDos攻撃等のマルチベクトル型攻撃に対する潜在的な脆弱性を塞ぎました。

バグに関しましては、以下のような問題を含めて計11個の修正がされました。

テーマテンプレートファイルのキャッシュに関連する問題。
特定の言語を使うユーザーがメディアファイルをアップロードできないようにするMediaElement JavaScriptに関するエラー。
Windowsベースのサーバーでテーマとプラグインファイルを編集できない問題。

 

(参照リンク:WordPress 4.9.1 Security Release)

対策版に関しましては下表のとおりです。

現在ご利用のバージョン
対策済みバージョン

1.5~3.6.1
4.9.1

3.7~3.7.23
4.9.1

3.8~3.8.23
4.9.1

3.9~3.9.21
4.9.1

4.0~4.0.20
4.9.1

4.1~4.1.20
4.9.1

4.2~4.2.17
4.9.1

4.3~4.3.13
4.9.1

4.4~4.4.12
4.9.1

4.5~4.5.11
4.9.1

4.6~4.6.8
4.9.1

4.7~4.7.7
4.9.1

4.8~4.8.3
4.9.1

4.9
4.9.1

(※2017年12月01日現在では各ブランチでの対策バージョンが出ておらず、4.9.1のみが対策されています)

※追記(2017年12月05日)
各ブランチでの対策バージョンが更新され、下表のとおりです。

現在ご利用のバージョン
対策済みバージョン

1.5~3.6.1
4.9.1

3.7~3.7.23
3.7.24

3.8~3.8.23
3.8.24

3.9~3.9.21
3.9.22

4.0~4.0.20
4.0.21

4.1~4.1.20
4.1.21

4.2~4.2.17
4.2.18

4.3~4.3.13
4.3.14

4.4~4.4.12
4.4.13

4.5~4.5.11
4.5.12

4.6~4.6.8
4.6.9

4.7~4.7.7
4.7.8

4.8~4.8.3
4.8.4

4.9
4.9.1

 

テーマに関しましては前述のとおり脆弱性が発生しませんでした。

 

プラグインに関しましては、先月から2件増加し21件の脆弱性が発見されました。そのうち有名プラグインに脆弱性が発見されました。

 

1つ目は、アクティブインストール500万以上、総ダウンロード数7577万以上の人気プラグイン『Yoast SEO』にクロスサイトスクリプティング(XSS)の脆弱性が発生しております。

このプラグインは、『All in One SEO Pack』と同じようにSEO対策が行えるプラグインです。

お使いの方は、バージョンの確認をすることを推奨します。

脆弱性はすでにアップデートによって修正済みで、バージョン5.8以上への更新によって塞ぐことができます。
(※2017年12月1日現在の最新版はバージョン5.8です。)

 

2つ目は、アクティブインストール100万以上、総ダウンロード数886万以上のプラグイン『Duplicator』にクロスサイトスクリプティング(XSS)の脆弱性が発生しております。

このプラグインは、WordPressサイトを丸ごと複製できるプラグインです。

お使いの方は、バージョンの確認をすることを推奨します。

脆弱性はすでにアップデートによって修正済みで、バージョン1.2.29以上への更新によって塞ぐことができます。
(※2017年12月1日現在の最新版はバージョン1.2.30ですのでこちらの最新版への更新をお勧めします。)

 

3つ目は、アクティブインストール70万以上、総ダウンロード数395万以上のプラグイン『Shortcodes Ultimate』にPRIVESCの脆弱性(権限が昇格する問題)が発生しております。

このプラグインは、ショートコードを利用してブログ記事を装飾できるプラグインです。

お使いの方は、バージョンの確認をすることを推奨します。

脆弱性はすでにアップデートによって修正済みで、バージョン5.0.1以上への更新によって塞ぐことができます。
(※2017年12月1日現在の最新版はバージョン5.0.1です。)

 

その他ご利用中の方が多い以下の人気プラグインにおいて脆弱性が発見されたため旧バージョンをご利用中の方は最新のプラグインにアップデートされることをお勧めいたします。

TablePressにてXMLエクスターナルエンティティ(XXE)
bbPressにてSQLインジェクション(SQLI)
Elementor Page BuilderにてPRIVESC
WP Mail Loggingにてクロスサイトスクリプティング(XSS)
WP Support Plus Responsive Ticket Systemにて遠隔でのコード実行が可能な脆弱性(RCE)

内容別レポート
脆弱性の内容別発生件数は、1位がXSSで10件、2位がSQLインジェクションで6件、3位がその他で4件でした。

トピックス
10月度と比較して、脆弱性の数が増加しており、XSSとSQLインジェクションは相変わらず発生件数が多いです。

先月よりXSSとSQLインジェクションはともに2件ずつ増加しております。
脆弱性一覧
2017年11月の脆弱性一覧をまとめましたのでご参照ください。

以下リストに掲載されている本体バージョン、プラグインがある方は、一度診断されることをお勧めいたします。

脆弱性分類ですが、掲載時点の内容の為、ご確認いただく時点で内容不明の分類が変更されている可能性もございますので、それもKYUBIにて最新の状態をご確認いただくことをお勧めします。

また、ご確認のタイミングによっては新たな脆弱性が発見されている可能性もございますので、こちらもKYUBIにて一度ご診断していただくことをお勧めします。

また、バージョンに関しましては、脆弱性情報が発見されたものを記載しておりますが、そのバージョン未満でも同様の脆弱性が発生している可能性がある為、最新版に更新することをお勧めしております。

但し、最新版でも脆弱性内容が修正されていないプラグインも少なからず存在しておりますので、対策されていないプラグインをご利用の方は、ご利用を控えるか、別の同様のプラグインに変更されることをお勧めします。

表:2017年11月度脆弱性一覧

発見個所
脆弱性分類
脆弱性のある本体・プラグイン・テーマの名称
発見されたVer.

本体
XSS
HTML Language Attribute Escaping
4.3.0-4.9

本体
UNKNOWN
‘newbloguser’ Key Weak Hashing
3.7-4.9

本体
XSS
RSS and Atom Feed Escaping
 1.5.0-4.9

本体
BYPASS
Authenticated JavaScript File Upload
 2.8.6-4.9

プラグイン
SQLI
InLinks
1.0

プラグイン
AUTHBYPASS
UserPro
 4.9.17

プラグイン
UNKNOWN
WPML Translation Management
2.4.1

プラグイン
XSS
Emag Marketplace Connector
1.0

プラグイン
XSS
Ultimate Instagram Feed
1.3

プラグイン
XSS
Ultimate Instagram Feed
1.3.1

プラグイン
PRIVESC
Elementor Page Builder
1.7.12

プラグイン
SQLI
JTRT Responsive Tables
 4.1

プラグイン
RCE
WP Support Plus Responsive Ticket System
8.0.7

プラグイン
XSS
WP Mail Logging
1.8.2

プラグイン
SQLI
Events
2.3.4

プラグイン
SQLI
Simple Events Calendar
1.3.5

プラグイン
XSS
Email Log
2.2.2

プラグイン
XSS
amtyThumb posts
8.1.3

プラグイン
XXE
TablePress
1.8

プラグイン
PRIVESC
Shortcodes Ultimate
5.0.0

プラグイン
SQLI
Active Directory Integration
1.1.8

プラグイン
XSS
Duplicator
1.2.28

プラグイン
XSS
Yoast SEO
5.7.1

プラグイン
MULTI
Formidable Forms
2.05.02

プラグイン
SQLI
bbPress