WordPress 2018年9月_脆弱性レポート  2018/10/1
2018年9月度のWordPressに関する脆弱性レポートをお知らせします。

9月度全体の脆弱性報告件数としては11件となっており、2018年8月度と同じ件数でした。
個所別レポート
個所別の発生件数は、それぞれ本体が0件、テーマが0件、プラグインが11件でした。

本体に関しまして、今月は脆弱性が発生しませんでした。

テーマに関しましも、今月は脆弱性が発生しませんでした。

先月に引き続き最多発生はプラグインとなり、脆弱性に気を配る必要があることがわかります。

ここ最近はプラグインのみで脆弱性が発見されることが多く、本体やテーマでは脆弱性が発見されにくくなってきています。本体はセキュリティアップデートを重ねていくうちに、脆弱性がなくなってきているのがわかります。

トピックス
前述のとおり本体に関しましては、脆弱性が発生しませんでした。

 

 

前述のとおりテーマに関しましては、脆弱性が発生しませんでした。

 

 

プラグインに関しましては先月から1件増加し、11件の脆弱性が発見されました。そのうち有名プラグインに脆弱性が発見されました。

 

1つ目は、アクティブインストール500万以上、総ダウンロード数9220万以上の人気プラグイン『Contact Form 7』にPRIVESCの脆弱性が発生しております。

このプラグインは、簡単にお問い合わせフォームを設置できるプラグインです。

意図されない権限昇格を許す脆弱性が5.0.3以前のバージョンに見つかっており、本来管理者と編集者にのみ許されるはずのコンタクトフォームの編集が、他のログインユーザーにも可能になってしまいます。

お使いの方も多いと思いますので、すぐにバージョンの確認をすることを推奨します。

脆弱性はすでにアップデートによって修正済みで、バージョン5.0.4以上への更新によって塞ぐことができます。
(※2018年10月1日現在の最新版もバージョン5.0.4となっております。)

 

2つ目は、アクティブインストール100万以上、総ダウンロード数1227万以上の人気プラグイン『Duplicator』にRCEの脆弱性が発生しております。

このプラグインは、WordPressで構築したサイトを丸ごとコピーできるプラグインです。

お使いの方は、バージョンの確認をすることを推奨します。

脆弱性はすでにアップデートによって修正済みで、バージョン1.2.42以上への更新によって塞ぐことができます。
(※2018年10月1日現在の最新版はバージョン1.2.48ですのでこちらの最新版への更新をお勧めします。)

 

その他ご利用中の方が多い以下の人気プラグインにおいて脆弱性が発見されたため、旧バージョンをご利用中の方は最新のプラグインにアップデートされることをお勧めいたします。

Breadcrumb NavXTにてユーザー名の露呈(「http://www.example.com/wp-json/bcn/v1/author/1」にアクセスすると露呈される)
File Managerにてクロスサイトスクリプティング(XSS)
Unysonにてファイルのダウンロードと展開を強制させる脆弱性
FV Flowplayer Video Playerにてクロスサイトスクリプティング(XSS)/li>

内容別レポート
脆弱性の内容別発生件数は、1位がXSSで4件、2位がLFIとその他で2件でした。

トピックス
8月度と比較してみると、XSSとLFIの発生件数が増加しております。

LFIの攻撃方法が比較的簡単になっていますので、注意が必要です。
脆弱性一覧
2018年9月の脆弱性一覧をまとめましたのでご参照ください。

以下リストに掲載されている本体バージョン、テーマ、プラグインがある方は、一度診断されることをお勧めいたします。

脆弱性分類ですが、掲載時点の内容の為、ご確認いただく時点で内容不明の分類が変更されている可能性もございますので、それもKYUBIにて最新の状態をご確認いただくことをお勧めします。

また、ご確認のタイミングによっては新たな脆弱性が発見されている可能性もございますので、こちらもKYUBIにて一度ご診断していただくことをお勧めします。

また、バージョンに関しましては、脆弱性情報が発見されたものを記載しておりますが、そのバージョン未満でも同様の脆弱性が発生している可能性がある為、最新版に更新することをお勧めしております。

但し、最新版でも脆弱性内容が修正されていないプラグインも少なからず存在しておりますので、対策されていないプラグインをご利用の方は、ご利用を控えるか、別の同様のプラグインに変更されることをお勧めします。

表:2018年9月度脆弱性一覧

発見個所
脆弱性分類
脆弱性のある本体・プラグイン・テーマの名称
発見されたVer.

プラグイン
SQLI
Image Intense
3.2.5

プラグイン
XSS
UserPro
4.9.23

プラグイン
LFI
Wechat Broadcast
1.2.0

プラグイン
XSS
File Manager
2.9

プラグイン
LFI
Localize My Post
1.0

プラグイン
UNKNOWN
Unyson
2.7.18

プラグイン
XSS
FV Flowplayer Video Player
6.1.2-6.6.4

プラグイン
XSS
FV Flowplayer Video Player
7.2.0.727

プラグイン
UNKNOWN
Breadcrumb NavXT
6.1.0

プラグイン
PRIVESC
Contact Form 7
5.0.3

プラグイン
RCE
Duplicator
1.2.40