WordPress 2019年2月_脆弱性レポート  2019/3/11
2019年2月度のWordPressに関する脆弱性レポートをお知らせします。

2月度全体の脆弱性報告件数としては11件となっており、2019年1月度から15件減少しております。
個所別レポート
個所別の発生件数は、それぞれ本体が1件、テーマが1件、プラグインが9件でした。

本体に関しまして、今月は脆弱性が発生しております。
2018年12月以来の発生となります。

テーマに関しましても先月に引き続き脆弱性が発生しております。

また、最多発生はプラグインとなり、脆弱性に気を配る必要があることがわかります。

トピックス
前述のとおり本体に関しまして、脆弱性が発生しております。

WordPress公式も発表していない、RCEの脆弱性が発見されています。

ただ、この脆弱性はバージョン5.0以下で発見された別の脆弱性に対するパッチで修正されたとのことなので、最新のWordPressでは行えないです。

このRCEの脆弱性についてはこちらの「WordPress 5.0.0 Remote Code Execution」をご覧ください。

英文になるのですが、攻撃方法等が詳しく記載されています。

この著者によりますと、6年以上前からこの脆弱性が存在しており、RCEの他にパストラバーサルの脆弱性もあったとのことです。

RCEは本体のバージョンを5.0.1以上にアップデートすれば問題ありませんが、パストラバーサルについては最新のWordPressでも行えるとのことなので十分に注意が必要です。

 

 

テーマに関しましては前述のとおり、1件脆弱性が発生しております。

「Newspaper」というテーマから、XSSの脆弱性が発見されました。

脆弱性はすでにアップデートによって修正済みで、バージョン9.5以上への更新によって塞ぐことができます。

 

 

プラグインに関しましては先月から16件減少し、9件の脆弱性が発見されました。そのうち2件の有名プラグインに脆弱性が発見されております。

 

1つ目は、アクティブインストール400万以上、総ダウンロード数6266万以上の人気プラグイン『WooCommerce』にXSSの脆弱性が発生しております。

このプラグインは、WordPress上でショッピングカートを動作させるプラグインです。

お使いの方も多いと思いますので、すぐにバージョンの確認をすることを推奨します。

脆弱性はすでにアップデートによって修正済みで、バージョン3.5.5以上への更新によって塞ぐことができます。
(※2019年3月11日現在の最新版はバージョン3.5.6ですのでこちらの最新版への更新をお勧めします。)

 

2つ目は、アクティブインストール90万以上、総ダウンロード数2494万以上の人気プラグイン『NextGen Gallery』にOBJECTINJECTIONの脆弱性が発生しております。

このプラグインは、多くの写真や画像を使ったギャラリーを作成し記事に簡単に設置することができるプラグインです。

お使いの方は、バージョンの確認をすることを推奨します。

脆弱性はすでにアップデートによって修正済みで、バージョン3.1.6以上への更新によって塞ぐことができます。
(※2019年3月11日現在の最新版はバージョン3.1.7ですのでこちらの最新版への更新をお勧めします。)

 

その他ご利用中の方が多い以下の人気プラグインにおいて脆弱性が発見されたため、旧バージョンをご利用中の方は最新のプラグインにアップデートされることをお勧めいたします。

LoginPressにてSQLインジェクション
Simple Social ButtonsにてBYPASS
ForminatorにてXSSとSQLインジェクション
Parallax ScrollにてXSS

内容別レポート
脆弱性の内容別発生件数は、1位がXSSで4件、2位がSQLiで2件でした。

トピックス
1月度と比較してみると、全体的に脆弱性の発生件数が減少しております。
ただ先月に引き続き、XSSの脆弱性は発見されやすい傾向にあるため、十分に注意が必要です。
脆弱性一覧
2019年2月の脆弱性一覧をまとめましたのでご参照ください。

以下リストに掲載されている本体バージョン、テーマ、プラグインがある方は、一度診断されることをお勧めいたします。

脆弱性分類ですが、掲載時点の内容の為、ご確認いただく時点で内容不明の分類が変更されている可能性もございますので、それもKYUBIにて最新の状態をご確認いただくことをお勧めします。

また、ご確認のタイミングによっては新たな脆弱性が発見されている可能性もございますので、こちらもKYUBIにて一度ご診断していただくことをお勧めします。

また、バージョンに関しましては、脆弱性情報が発見されたものを記載しておりますが、そのバージョン未満でも同様の脆弱性が発生している可能性がある為、最新版に更新することをお勧めしております。

但し、最新版でも脆弱性内容が修正されていないプラグインも少なからず存在しておりますので、対策されていないプラグインをご利用の方は、ご利用を控えるか、別の同様のプラグインに変更されることをお勧めします。

表:2019年2月度脆弱性一覧

発見個所
脆弱性分類
脆弱性のある本体・プラグイン・テーマの名称
発見されたVer.

本体
RCE
本体
3.7-5.0

テーマ
XSS
Newspaper Theme
9.2.2

プラグイン
TRAVERSAL
WP Cost Estimation
9.660

プラグイン
UPLOAD
WP Cost Estimation
9.644

プラグイン
XSS
Forminator
1.5.4

プラグイン
SQLI
Forminator
1.5.4

プラグイン
SQLI
LoginPress
1.1.15

プラグイン
BYPASS
Simple Social Buttons
2.0.4-2.0.21

プラグイン
XSS
Parallax Scroll
2.0.1

プラグイン
XSS
WooCommerce
3.5.4

プラグイン
OBJECTINJECTION
NextGen Gallery
3.1.5