WordPress 2020年2月_脆弱性レポート  2020/3/11
2020年2月度のWordPressに関する脆弱性レポートをお知らせします。

2月度全体の脆弱性報告件数としては25件となっており、2020年1月度から23件減少しております。
個所別レポート
個所別の発生件数は、それぞれ本体が0件、テーマが1件、プラグインが24件でした。

本体に関しまして、今月は脆弱性が発生しませんでした。

テーマに関しましては、今月も脆弱性が発生しております。
先月に引き続いての発生となります。

また、最多発生はプラグインとなり、脆弱性に気を配る必要があることがわかります。

トピックス
前述のとおり本体に関しましては、脆弱性が発生しませんでした。

 

 

テーマに関しましては、1件脆弱性が発生しております。

「Fruitful Theme」というテーマから、XSSの脆弱性が発見されました。

脆弱性はすでにアップデートによって修正済みで、バージョン3.8.1以上への更新によって塞ぐことができます。

 

 

プラグインに関しましては先月から11件減少し、24件の脆弱性が発見されました。そのうち1件の有名プラグインに脆弱性が発見されております。

 

アクティブインストール100万以上、総ダウンロード数1945万以上の人気プラグイン『Duplicator』にAUTHBYPASSの脆弱性が発生しております。

このプラグインは、WordPressで構築したサイトを丸ごとコピーできるプラグインです。

お使いの方は、バージョンの確認をすることを推奨します。

脆弱性はすでにアップデートによって修正済みで、バージョン1.3.28以上への更新によって塞ぐことができます。

 

その他ご利用中の方が多い以下の人気プラグインにおいて脆弱性が発見されたため、旧バージョンをご利用中の方は最新のプラグインにアップデートされることをお勧めいたします。

Photo GalleryにてXSS
Async JavascriptにてXSS
Envira Photo GalleryにてXSS
Popup BuilderにてSQLI

内容別レポート
脆弱性の内容別発生件数は、1位がXSSで10件、2位がCSRFとBYPASSで4件でした。

トピックス
BYPASSの発見件数が比較的多い月となりました。
また、今月はその他の項目にてBACKDOORの脆弱性が1件発見されており、十分に注意が必要です。
脆弱性一覧
2020年2月の脆弱性一覧をまとめましたのでご参照ください。

以下リストに掲載されている本体バージョン、テーマ、プラグインがある方は、一度診断されることをお勧めいたします。

脆弱性分類ですが、掲載時点の内容の為、ご確認いただく時点で内容不明の分類が変更されている可能性もございますので、それもKYUBIにて最新の状態をご確認いただくことをお勧めします。

また、ご確認のタイミングによっては新たな脆弱性が発見されている可能性もございますので、こちらもKYUBIにて一度ご診断していただくことをお勧めします。

また、バージョンに関しましては、脆弱性情報が発見されたものを記載しておりますが、そのバージョン未満でも同様の脆弱性が発生している可能性がある為、最新版に更新することをお勧めしております。

但し、最新版でも脆弱性内容が修正されていないプラグインも少なからず存在しておりますので、対策されていないプラグインをご利用の方は、ご利用を控えるか、別の同様のプラグインに変更されることをお勧めします。

表:2020年2月度脆弱性一覧

発見個所
脆弱性分類
脆弱性のある本体・プラグイン・テーマの名称
発見されたVer.

プラグイン
BYPASS
Booked
2.2.6

プラグイン
XSS
Async Javascript
2.20.02.27

プラグイン
XSS
Modern Events Calendar Lite
5.1.7

プラグイン
XSS
10Web Map Builder for Google Maps
1.0.64

プラグイン
BACKDOOR
wpdefault
no known fix

プラグイン
CSV Injection
Export Users to CSV
1.4.2

プラグイン
XSS
WPJobBoard
5.5.3

プラグイン
XSS
Envira Photo Gallery
1.7.7

プラグイン
BYPASS
Flexible Checkout Fields for WooCommerce
2.3.2

プラグイン
XSS
Hero Maps Premium
2.2.3

プラグイン
XSS
Photo Gallery
1.5.46

プラグイン
CSRF
Pricing Table by Supsystic
1.8.1

プラグイン
CSRF
Ultimate Membership Pro
8.6.2

プラグイン
BYPASS
CardGate
3.1.16

プラグイン
AUTHBYPASS
Duplicator
1.3.24 & 1.3.26

プラグイン
XSS
Modula Image Gallery
2.2.5

プラグイン
CSRF
Easy Property Listings
3.4

プラグイン
RCE
ThemeREX Addons

プラグイン
PRIVESC
wpCentral
1.5.1

プラグイン
SQLI
Popup Builder
3.0

プラグイン
XSS
GDPR Cookie Consent
1.8.3

プラグイン
BYPASS
Profile Builder and Profile Builder Pro
3.1.1

プラグイン
CSV Injection
Events Manager Pro
2.6.7.2

プラグイン
CSRF
Tutor LMS
1.5.3

テーマ
XSS
Fruitful Theme
3.8